KYC Performance degraded on Production
Incident Report for Sila
Resolved
KYC should be operational now on Production.
Posted Mar 19, 2021 - 00:15 UTC
Investigating
We are moving some ethereum around from our Betalist authorized address which will cause some delay in KYC on Production
Posted Mar 18, 2021 - 23:39 UTC
This incident affected: Production API.